Search
Log in
Login:
Password:
Register
Forgot your password?

Aktakom DSO-Reader Pro Software for Oscilloscopes


AKTAKOM DSO-Reader Pro is an application software to read data from AKTAKOM digital oscilloscopes.

Compatible with:†ADS-2031 Digital Storage Oscilloscope,†ADS-2031V Digital Storage Oscilloscope,†ADS-2061M Digital Storage Oscilloscope,†ADS-2061MV Digital Storage Oscilloscope,†ADS-2111M Digital Storage Oscilloscope,†ADS-2111MV Digital Storage Oscilloscope,†ADS-2121M Digital Storage Oscilloscope,†ADS-2121MV Digital Storage Oscilloscope,†ADS-2221M Digital Storage Oscilloscope,†ADS-2221MV Digital Storage Oscilloscope,†ADS-2322 Digital Storage Oscilloscope,†ADS-2332 Digital Storage Oscilloscope
For Windows®
Supported OS:†Windows XP x32,†Windows XP x64,†Windows 7 x32,†Windows 7 x64,†Windows 8 x32,†Windows 8 x64,†Windows 8.1 x64

Features

Read data is displayed on oscillogram graphs, spectrograph, there is ability for signal digital filtering, cursor and automatic measurements, file recording and data reading.

Program user interface consists of workspaces (windows). Every workspace contains controls set (Controls) which allows user to influence the program operation as well as indicators which display the necessary information. Comparing to Controls user can not influence the indicators directly. The majority of these controls are the part of Windows standard interface and do not require any special usage explanations.

Signal processing provides the following:

Program decimation:

  • Sampling
  • Average
  • Median
  • Peak

Interpolation:

  • SinX/X
  • Bessel spline
  • Akima spline
  • Automayic

Filtration:

  • Accumulative
  • Polynomial
  • Spectral

Geometrical effects:

  • Flip
  • Invert
  • Strengthen
  • Stretch
  • Add noise

Displaying in the following modes: points, lines, spline.

Mathematical processing:

  • Sum, difference, ratio, channels multiplication
  • Channel geometric average value
  • Derivative of the selected channel
  • Integral of the selected channel
  • Integral of channels multiplication
  • Transfer function of channel A to B

Additional capabilities:

  • Adjustable signals emulation
  • Comparison of the signal with the pattern
  • Alarm signaling
  • Spectral synthesis

Main window

The general view is shown in the below picture.

Description of Controls and indicators

Connection – button used to connect to the device and text field for results messages. If you run the program with the device switched on and connected to the PC already the connection should be automatic.

File – group of elements for recording/reading of a single file or series of files. Functions of record () and read () differ a little bit from the relative commands of File menu.

Record button functions completely similar to menu command “Record the data file” in case “Record time” switcher is off. If this switcher is on the record data clicking will record the first data file by an ordinary method and further on there should be automatic recoding of another file after next oscillograms collection. The process will last till the time specified in “Record time” field is over. The name of the automatically recorded file consists of the name of the firstly selected file adding the order number in hexadecimal format.

Similarly read button opens the first file suggesting user to select it manually and afterwards checks the availability of the automatically recorded files to it. If there are any of them they will be automatically loaded by turn. This capability allows recording and viewing the interactive changing of the waveform

Read – group of elements used to display data read from the device – button to start/stop reading, parameters of sweeping and the channels ranges, oscillograms graph and cursor and marking measurement panel.

Graph
To identify absolute or relative mark position on the graph you may use cursors.

Besides the cursors which can be moved on the graph by left-clicking you may use right-clicking to set 10 fixed marks. These marks can be used both for measurement and for data bulk navigation.

General settings tab:

Events sound recording – allows using the program sound messages (the computer should be equipped with audio system). It doesn’t affect the sound use for Windows standard messages.

Pop-up tips – allows using pop-up signatures of the elements of the program user interface. If you are good at the program operation processes we recommend to switch this option off to speed up the program work and eliminate the visible noises.

Selection of the oscillogram area under analysis – allows user to specify which part of the collected data the program should forward to the analysis module.

Possible variants:

  • The whole oscillogram – all of the collected data will be analyzed;
  • Part displayed on the main graph – we analyze “what we see”;
  • Between the cursors of the main graph – the area under analysis is specified with cursors;
  • Between user’s two latest marks - the area under analysis is specified with the user’s marks (which are set with right-clicking by the oscillogram screen).

If the selected method can’t be used the program will automatically switch to the previous one in the list. For example if it’s selected to analyze the area between user’s marks but the marks themselves haven’t been specified the program will choose the method “between the cursors”. If the cursors are hidden the area on the main graph will be analyzed.

Graphics settings tab:

It allows user to set the needed colors of different graphs elements. Left-clicking allows you to choose the color, right-clicking sets the color on default.

Drop-down list below allows selecting some of the standard color schemes. Buttons to the right of the list allows saving into files and loading from files user color schemes.

Line thickness – sets the thickness of oscillograms lines in pixels in the main window. On default the graphs lines has thickness of 1 pixel for maximum clear waveform image. However at high resolution printing or when viewing these oscillograms on a big screen (e.g. when using a projector) very thin lines can turn to be hardly viewed. By using this parameter you may solve this problem. Note: increasing of this parameter may course retardation of graph redrawing, therefore use it with proper care.

Discretization tab:

Decimation group controls decimation functions of the received oscillograms. Scale sets the quantity of decimation points (e.g. 1:10 means leaving in the oscillogram 1 point from every 10). Method describes the decimation way: “Sampling” – there is only 1 point selected on the area without amplitude correction. “Average” – there is arithmetical mean taken from the amplitude of the area sampling. “Median” – the area is displayed as a median point. “Peak” – the minimum and maximum values of the area amplitude are taken alternately.

Interpolation is a function opposite to decimation and allows you to mathematically restore oscillogram points missed between discretization moments.

Use may manually choose 1 of 3 interpolation algorithms (SinX/X, Bessel spline, Akima spline) or choose automatic algorithm selection (recommended).

Measurements tab:

Displays automatically measured frequency and amplitude and mean square value for two channels. It duplicates the similar measurements from Analysis module.

Main menu

File Menu

Reading data from a file… - used to select the file to read the previously recorded data.
Writing data to a file… - used to select a file to record the current data.
Save image to file… - used to select a file and write the current oscillogram image into it.
Save configuration… - used to save the program settings into file.
Load the configuration… - used to restore the program settings from file.
Print… - used to print the oscillogram image.
Printing preferences… - used to call for the printer customization dialog.
Exit… - used to exit the program with further closing of all its data files.

View menu

Net – used to open/close the net on the oscillogram graph.
X-Y figure – used to open/close Lissajous figure on two channels.
Infinit Persistence – used to select the oscilloscope “afterglow” mode.
Style of drawing waveforms – used to display the oscillograms in points, in broken or distorted lines.

Help menu

Contains commands to call the current help file and the window of the program brief information.

This software in its standard representation doesn’t have any data medium. It can be downloaded from www.tmatlantic.com after your device registration by entering its serial number. You may download the software files after the invoice payment (you will receive the code for download).

It’s recommended to make a timely backup copy of the received files. The loss of the software or the download code will cause extra payment. This software can be recorded to a CD. CD recording and its delivery will also cost some extra payment.

Frequently Asked Questions

  • How to install Aktakom DSO-Reader Pro Software?

  • How to install Aktakom DSO-Reader Pro Software?

    When you buy Aktakom DSO-Reader Pro you will receive *.exe file which is a setup file. Run this setup file and follow the instruction as you may see in the pictures below:

    Read attentively the license agreement.

    Follow the installer instructions.

    Check “Install USB driver” for the automatic setup of the driver and then click “Finish”

    After the drive setup is completed the software is ready for further work.

    If due to some reasons the device wasn’t identified after the connection – you may install the driver manually.

    Call Device manager. Find Oscilloscope there.

    Open its properties, click Update Driver. You will see the following window:

    Click Next and wait till the installation is completed.

    As a result you should see the following

    The driver is ready for further work.


    Up

    ALL RIGHTS RESERVED. AKTAKOMô software is protected under International and Federal Copyright Laws and Treaties. Any unauthorized copy, reprint or use of this material is prohibited. No part of this software may be reproduced or transmitted in any form or by any means, electronic or mechanical, including photocopying, recording, or by any information storage and retrieval system without express written permission from the author / publisher.

    Windows, Windows logo are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.


    Back to the section